use strict;
my $str = 'Name1 `Value1` Name2 `Value2` `Name3` Value3
';
my $regex = qr/\w*\`\b/mp;
my $subst = '`;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";