import re
regex = re.compile(r"\w*\`\b", flags=re.MULTILINE)
test_str = ("Name1 `Value1` Name2 `Value2` `Name3` Value3 \n")
subst = "`;"
result = regex.sub(subst, test_str)
if result:
print(result)