// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w*\`\b").unwrap();
let string = "Name1 `Value1` Name2 `Value2` `Name3` Value3
";
let substitution = "`;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}