re = /\w*\`\b/m
str = 'Name1 `Value1` Name2 `Value2` `Name3` Value3
'
subst = '`;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result