package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div class="btn (.*?)<\/div>`)
var str = `<div class="btn btn-success" ng-show="beingEdited" ng-disabled="ncrForm.$invalid" ng-click="save()"><span translate="ACTIONS.SAVE">Kaydet</span></div>
`
var substitution = "<span class="$1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}