// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div class="btn (.*?)<\/div>"#).unwrap();
let string = "<div class=\"btn btn-success\" ng-show=\"beingEdited\" ng-disabled=\"ncrForm.$invalid\" ng-click=\"save()\"><span translate=\"ACTIONS.SAVE\">Kaydet</span></div>
";
let substitution = "<span class=\"$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}