const regex = /<div class="btn (.*?)<\/div>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="btn (.*?)<\\\/div>', 'gm')
const str = `<div class="btn btn-success" ng-show="beingEdited" ng-disabled="ncrForm.\$invalid" ng-click="save()"><span translate="ACTIONS.SAVE">Kaydet</span></div>
`;
const subst = `<span class="$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);