import Foundation
let pattern = #"<div class="btn (.*?)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="btn btn-success" ng-show="beingEdited" ng-disabled="ncrForm.$invalid" ng-click="save()"><span translate="ACTIONS.SAVE">Kaydet</span></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)