re = /<div class="btn (.*?)<\/div>/m
str = '<div class="btn btn-success" ng-show="beingEdited" ng-disabled="ncrForm.$invalid" ng-click="save()"><span translate="ACTIONS.SAVE">Kaydet</span></div>
'
subst = '<span class="$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result