use strict;
my $str = '<div class="btn btn-success" ng-show="beingEdited" ng-disabled="ncrForm.$invalid" ng-click="save()"><span translate="ACTIONS.SAVE">Kaydet</span></div>
';
my $regex = qr/<div class="btn (.*?)<\/div>/mp;
my $subst = '<span class="$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";