# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(one|two words)\s(.*)/$1$3/g;t' <<< "
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word"