use strict;
my $str = '
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word';
my $regex = qr/(.*)(one|two words)\s(.*)/p;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";