import Foundation
let pattern = #"(.*)(one|two words)\s(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)