package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(one|two words)\s(.*)`)
var str = `
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}