# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)(one|two words)\s(.*)"
test_str = ("\n"
"line with one word in it - works great\n\n"
"line with two words in it - does not work - it only excludes the first word")
subst = "$1$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.