const regex = /(.*)(one|two words)\s(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(one|two words)\\s(.*)', 'g')
const str = `
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);