// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)(one|two words)\s(.*)").unwrap();
let string = "
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}