#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)(one|two words)\s(.*)"
Local $sString = "" & @CRLF & _
"line with one word in it - works great" & @CRLF & _
"" & @CRLF & _
"line with two words in it - does not work - it only excludes the first word"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)