using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(one|two words)\s(.*)";
string substitution = @"$1$3";
string input = @"
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}