$re = '/(.*)(one|two words)\s(.*)/';
$str = '
line with one word in it - works great
line with two words in it - does not work - it only excludes the first word';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;