#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/time>\s\s\s<a href=\"(.*?)\" "
Local $sString = "lass="js-thumb-slider playlist_list">" & @CRLF & _
" <noscript>" & @CRLF & _
" <li>" & @CRLF & _
" <time datetime="2018-03-18T00:09:28.000+0000"></time> " & @CRLF & _
"" & @CRLF & _
"<a href="https://www.example.com/" title=">dsfsdf</a>" & @CRLF & _
" </li>" & @CRLF & _
" <li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")