re = /<\/time>\s\s\s<a href=\"(.*?)\" /m
str = 'lass="js-thumb-slider playlist_list">
<noscript>
<li>
<time datetime="2018-03-18T00:09:28.000+0000"></time>
<a href="https://www.example.com/" title=">dsfsdf</a>
</li>
<li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end