package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/time>\s\s\s<a href=\"(.*?)\" `)
var str = `lass="js-thumb-slider playlist_list">
<noscript>
<li>
<time datetime="2018-03-18T00:09:28.000+0000"></time>
<a href="https://www.example.com/" title=">dsfsdf</a>
</li>
<li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}