import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/time>\\s\\s\\s<a href=\\\"(.*?)\\\" ";
final String string = "lass=\"js-thumb-slider playlist_list\">\n"
+ " <noscript>\n"
+ " <li>\n"
+ " <time datetime=\"2018-03-18T00:09:28.000+0000\"></time> \n\n"
+ "<a href=\"https://www.example.com/\" title=\">dsfsdf</a>\n"
+ " </li>\n"
+ " <li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}