import Foundation
let pattern = #"<\/time>\s\s\s<a href=\"(.*?)\" "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
lass="js-thumb-slider playlist_list">
<noscript>
<li>
<time datetime="2018-03-18T00:09:28.000+0000"></time>
<a href="https://www.example.com/" title=">dsfsdf</a>
</li>
<li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)