using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/time>\s\s\s<a href=\""(.*?)\"" ";
string input = @"lass=""js-thumb-slider playlist_list"">
<noscript>
<li>
<time datetime=""2018-03-18T00:09:28.000+0000""></time>
<a href=""https://www.example.com/"" title="">dsfsdf</a>
</li>
<li>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}