use strict;
my $str = 'lass="js-thumb-slider playlist_list">
<noscript>
<li>
<time datetime="2018-03-18T00:09:28.000+0000"></time>
<a href="https://www.example.com/" title=">dsfsdf</a>
</li>
<li>';
my $regex = qr/<\/time>\s\s\s<a href=\"(.*?)\" /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}