$re = '/<\/time>\s\s\s<a href=\"(.*?)\" /m';
$str = 'lass="js-thumb-slider playlist_list">
<noscript>
<li>
<time datetime="2018-03-18T00:09:28.000+0000"></time>
<a href="https://www.example.com/" title=">dsfsdf</a>
</li>
<li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);