import re
regex = re.compile(r"<\/time>\s\s\s<a href=\"(.*?)\" ", flags=re.MULTILINE)
test_str = ("lass=\"js-thumb-slider playlist_list\">\n"
" <noscript>\n"
" <li>\n"
" <time datetime=\"2018-03-18T00:09:28.000+0000\"></time> \n\n"
"<a href=\"https://www.example.com/\" title=\">dsfsdf</a>\n"
" </li>\n"
" <li>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")