# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/img\/([^\/]+)(?i:\.jpe?g)$/\/img-cleaned-up\/$1\.jpg/gm;t' <<< "/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG"