# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/img/([^/]+)(?i:\.jpe?g)$"
test_str = ("/home/my/siteblog\n"
"/home/my/siteblog/img/example.jpg\n"
"/home/my/siteblog/img/example.JPG\n"
"/home/my/siteblog/img/another-image.jpeg\n"
"/home/my/siteblog/img/stupid-extension.jpEG")
subst = "/img-cleaned-up/$1\\.jpg"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.