#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/img/([^/]+)(?i:\.jpe?g)$"
Local $sString = "/home/my/siteblog" & @CRLF & _
"/home/my/siteblog/img/example.jpg" & @CRLF & _
"/home/my/siteblog/img/example.JPG" & @CRLF & _
"/home/my/siteblog/img/another-image.jpeg" & @CRLF & _
"/home/my/siteblog/img/stupid-extension.jpEG"
Local $sSubst = "/img-cleaned-up/$1\.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)