import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/img/([^/]+)(?i:\\.jpe?g)$";
final String string = "/home/my/siteblog\n"
+ "/home/my/siteblog/img/example.jpg\n"
+ "/home/my/siteblog/img/example.JPG\n"
+ "/home/my/siteblog/img/another-image.jpeg\n"
+ "/home/my/siteblog/img/stupid-extension.jpEG";
final String subst = "/img-cleaned-up/$1\\.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}