const regex = new RegExp('/img/([^/]+)(?i:\\.jpe?g)$', 'gm')
const str = `/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG`;
const subst = `/img-cleaned-up/$1\.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);