import Foundation
let pattern = #"/img/([^/]+)(?i:\.jpe?g)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/img-cleaned-up/$1\.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)