$re = '~/img/([^/]+)(?i:\.jpe?g)$~m';
$str = '/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG';
$subst = "/img-cleaned-up/$1\.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;