use strict;
my $str = '/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG';
my $regex = qr~/img/([^/]+)(?i:\.jpe?g)$~mp;
my $subst = '/img-cleaned-up/$1\\.jpg';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";