using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/img/([^/]+)(?i:\.jpe?g)$";
string substitution = @"/img-cleaned-up/$1\.jpg";
string input = @"/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}