package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/img/([^/]+)(?i:\.jpe?g)$`)
var str = `/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG`
var substitution = "/img-cleaned-up/$1\.jpg"
fmt.Println(re.ReplaceAllString(str, substitution))
}