# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*[\n]*)((pattern)([\n]*))(.*)/$1blah$4$5/gm;t' <<< "first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
"