use strict;
my $str = 'first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
';
my $regex = qr/(.*[\n]*)((pattern)([\n]*))(.*)/mp;
my $subst = '$1blah$4$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";