using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[\n]*)((pattern)([\n]*))(.*)";
string substitution = @"$1blah$4$5";
string input = @"first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}