// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*[\n]*)((pattern)([\n]*))(.*)").unwrap();
let string = "first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
";
let substitution = "$1blah$4$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}