import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*[\\n]*)((pattern)([\\n]*))(.*)";
final String string = "first textpatternsecond text\n\n"
+ "first text\n"
+ "pattern\n"
+ "second text\n\n\n"
+ "first text\n\n\n"
+ "pattern\n\n"
+ "second text\n";
final String subst = "$1blah$4$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}