package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*[\n]*)((pattern)([\n]*))(.*)`)
var str = `first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
`
var substitution = "$1blah$4$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}