re = /(.*[\n]*)((pattern)([\n]*))(.*)/m
str = 'first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
'
subst = '$1blah$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result