#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*[\n]*)((pattern)([\n]*))(.*)"
Local $sString = "first textpatternsecond text" & @CRLF & _
"" & @CRLF & _
"first text" & @CRLF & _
"pattern" & @CRLF & _
"second text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"first text" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"pattern" & @CRLF & _
"" & @CRLF & _
"second text" & @CRLF & _
""
Local $sSubst = "$1blah$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)