$re = '/(.*[\n]*)((pattern)([\n]*))(.*)/m';
$str = 'first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
';
$subst = "$1blah$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;