import Foundation
let pattern = #"(.*[\n]*)((pattern)([\n]*))(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
first textpatternsecond text
first text
pattern
second text
first text
pattern
second text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1blah$4$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)