# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{2}\/\d{2}\/\d{2,4}$//gm;t' <<< "My birthday is 11/13/2018
Another way is to say 11/13/18
And the day after 11/13/2018 is 11/14/2018"